LNMP 1.4 下升级 Memcached 到最新版

LNMP 1.4里内置的是 Memcached 1.4.36 版本,而 Memcached 官方网站已经更新到1.5.0版了,对于强迫症的我来说,这明显很不科学呀,嘿嘿。那么升级之是必须的。

memcached.png

在LNMP论坛里找到了军哥的一个帖子回复,里面提到了升级 Memcached 的方法,特此分享出来,并且这个方法还适合用来升级LNMP里很多的模块版本,可以说举一反三的话很实用的。

具体如下:

修改lnmp1.4/include/version.sh 里的Memcached_Ver的版本号为你要升级到的版本号,这里我填的是1.5.0。

还需要将 include/memcached.sh 中下面这几行

    if [ -s /usr/local/memcached/bin/memcached ]; then
        echo "Memcached already exists."
    else

useradd -s /sbin/nologin nobody 后的 fi 删掉后再进行下面的升级memcached。

将你自己需要的版本的memcached下载到 src 目录下,运行 ./addons.sh install memcached安装编译即可。

Memcached 1.5.0下载地址列表:https://github.com/memcached/memcached/wiki/ReleaseNotes

在version.sh里包括了很多LNMP模块的版本号的,所以举一反三就知道如何升级这些模块了。

最后修改:2017 年 08 月 20 日 09 : 00 PM
如果觉得我的文章对你有用,请随意赞赏

6 条评论

  1. 老地儿

    博主好喜欢折腾呀!

    1. 明月登楼
      @老地儿

      生命不止,折腾不息!

  2. Zero

    您的主题比较好,能不能分享一份给我,谢谢

    1. 明月登楼
      @Zero

      不好意思,这个是收费主题,我无权分享的!

      1. Zero
        @明月登楼

        我支付可以吗

        1. 明月登楼
          @Zero

          呵呵,当然可以了,那你直接联系主题作者购买吧:https://www.ihewro.com/archives/489/

发表评论